首頁>Ubuntu>source

我正在尝試安裝 lablgtk 通過以下方式:

opam install lablgtk

它给我以下錯誤:

┌─ The following actions failed
│ λ build lablgtk 2.18.11
└─ 
╶─ No changes have been performed
<><> lablgtk.2.18.11 troubleshooting ><><><><><><><><><><><><><><><><><><><><><>
=> This package requires gtk+ 2.0 development packages installed on your system
The packages you requested declare the following system dependencies. Please
make sure they are installed before retrying:
    libexpat1-dev libgtk2.0-dev

我尝試了這个: sudo apt-get install -y libgtk2.0-dev 但它說 libgtk2.0-dev is already the newest version (2.24.32-1ubuntu1).

類似的情况也發生在: sudo apt-get install -y libexpat1-dev 我在哪裏

我在Ubuntu 18.04LTS和20.04LTS上都尝試過.有什麼建議可以解決吗?

完整的輸出:

libexpat1-dev is already the newest version (2.2.5-3ubuntu0.2).

∗ install lablgtk 2.18.11 <><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><> [lablgtk.2.18.11] found in cache <><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><> [ERROR] The compilation of lablgtk failed at "/home/user/.opam/opam-init/hooks/sandbox.sh build ./configure --prefix /home/user/.opam/default LABLGLDIR=/home/user/.opam/default/lib/lablgl". #=== ERROR while compiling lablgtk.2.18.11 ====================================# # context 2.0.7 | linux/x86_64 | | https://opam.ocaml.org#87778c51 # path ~/.opam/default/.opam-switch/build/lablgtk.2.18.11 # command ~/.opam/opam-init/hooks/sandbox.sh build ./configure --prefix /home/user/.opam/default LABLGLDIR=/home/user/.opam/default/lib/lablgl # exit-code 1 # env-file ~/.opam/log/lablgtk-32104-d0f245.env # output-file ~/.opam/log/lablgtk-32104-d0f245.out ### output ### # [...] # checking whether C compiler accepts -fno-unwind-tables... yes # checking platform... Unix # checking native dynlink... checking for pkg-config... /home/linuxbrew/.linuxbrew/bin/pkg-config # checking for GTK+ - version >= 2.0.0... Package gtk+-2.0 was not found in the pkg-config search path. # Perhaps you should add the directory containing `gtk+-2.0.pc' # to the PKG_CONFIG_PATH environment variable # No package 'gtk+-2.0' found # no # *** Could not run GTK+ test program, checking why... # *** The test program failed to compile or link. See the file config.log for the # *** exact error that occured. This usually means GTK+ is incorrectly installed. # configure: error: GTK+ is required <><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><> ┌─ The following actions failed │ λ build lablgtk 2.18.11 └─ ╶─ No changes have been performed <><> lablgtk.2.18.11 troubleshooting ><><><><><><><><><><><><><><><><><><><><><> => This package requires gtk+ 2.0 development packages installed on your system The packages you requested declare the following system dependencies. Please make sure they are installed before retrying: libexpat1-dev libgtk2.0-devwhich opam/usr/local/bin/opamwhich ocaml

/home/linuxbrew/.linuxbrew/bin/ocaml
最新回復
  • 5月前
    1 #

    我看到您正在使用LinuxBrew在Ubuntu上安裝东西。 它可能對其他东西有好處,但是在当前情况下,它会匯致無法預測和不可再現的結果。

    因此,我建議删除使用LinuxBrew安裝的OPAM和OCaML,然後使用官方儲存庫中的deb-packages安裝所有內容。

    brew uninstall ocaml-findlib
    brew uninstall ocaml
    brew uninstall opam
    brew uninstall gcc
    brew uninstall [email protected]
    rm -rf ~/.opam
    sudo rm -v /usr/local/bin/opam
    

    然後安裝ProVerif,我们可以遵循ArchLinux的PKGBUILD。

    sudo apt install -y graphviz ocaml-nox liblablgtk2-ocaml-dev
    cd ~/Downloads
    wget http://prosecco.gforge.inria.fr/personal/bblanche/proverif/proverif2.02pl1.tar.gz
    tar -xf proverif2.02pl1.tar.gz
    cd proverif2.02pl1/
    ./build
    # optionally run tests
    #./test all
    #./test-type all
    # and install binaries
    sudo install -Dm755 proverif /usr/local/bin/proverif
    sudo install -Dm755 proveriftotex /usr/local/bin/proveriftotex
    

    然後从任何地方以 proverif方式呼叫可執行檔案 或 proveriftotex

  • firefox:如何在wine中安裝HTML(Gecko)支援?
  • command line:如何清除vim的终端歷史記錄?